tftp

Pointing Mikrotik RouterOS hardware logging to a remote Syslog server

This is a really quick article in passing really. I needed to configure my RouterBoard to point to my Syslog server for some testing purposes so I thought I’d document the process for others who might be trying to achieve the same thing.

To set up logging on RouterOS, run the following on your device
Note: I am using RouterOS v.5. I don’t have any hardware running other versions to verify if this also works on older versions of RouterOS

In the below example, the IP address 10.0.1.80 is my remote syslog server.

[admin@routeros] > /system logging action set remote bsd-syslog=yes name=remote remote=10.0.1.80 remote-port=514 src-address=0.0.0.0 syslog-facility=local0 syslog-severity=auto target=remote
[admin@routeros] > /system logging add action=remote disabled=no prefix="" topics=!async

I hope this has proven useful.

Adding CloneZilla to your existing PXE deployment model

Firstly, thanks again to Gavin Spurgeon for his assistance with getting this solution working smoothly.

Two days ago I wrote an article about setting up PXE network booting. This is very useful when it comes to quick provisioning with Kickstarts or other utilities.
You can find my article here if you’d like to run through setting up PXE in your environment.

In this article, I’ll be covering for those Windows usersĀ amongst you, how to use CloneZilla (Open Source alternative to Symantec Ghost) combined with PXE to quickly deploy your company Standard Operating Environments (SOE’s).

Continue reading “Adding CloneZilla to your existing PXE deployment model” »

Creating a PXE Deployment server with Red Hat Enterprise Linux 6

If you currently don’t have any structured means of managing deployments of Standard Operating Environments (SOE’s) in your organization, I seriously urge you to read on as learning how to deploy images over a network connection will save you a huge amount of time.

This guide will walk you through setting up a PXE boot server for you to deploy any form of network bootable operating systems.

A bit of background on this topic as to new users this will or is already a very confusing topic.
For starters, there is no such software called a “pxe server”. A PXE implementation is simply a combination of DHCP and a normal TFTP Server. The reason it is called PXE is because this is an acronym for “Preboot Execution Environment”.

Continue reading “Creating a PXE Deployment server with Red Hat Enterprise Linux 6” »