RouterOS

DNS Conditional forwarders with Mikrotik RouterOS

If you have been following some of my recent articles, you may have noticed that I am covering a few topics which are typical for joining multiple environments together.

One of these topics has been setting up DNS forwarding based on a per zone basis. This is a typical requirement for Active Directory Domain trusts and other related tasks.

This article will cover how to set up a DNS conditional forwarder on a RouterOS based device.

In this example, I will be using the below details

RouterOS Version:                  5.15
RouterOS IP Address:               10.0.0.254
Example.com DNS server IP Address: 10.0.1.11
Domain.com DNS server IP Address:  10.0.4.11

Continue reading “DNS Conditional forwarders with Mikrotik RouterOS” »

Pointing Mikrotik RouterOS hardware logging to a remote Syslog server

This is a really quick article in passing really. I needed to configure my RouterBoard to point to my Syslog server for some testing purposes so I thought I’d document the process for others who might be trying to achieve the same thing.

To set up logging on RouterOS, run the following on your device
Note: I am using RouterOS v.5. I don’t have any hardware running other versions to verify if this also works on older versions of RouterOS

In the below example, the IP address 10.0.1.80 is my remote syslog server.

[admin@routeros] > /system logging action set remote bsd-syslog=yes name=remote remote=10.0.1.80 remote-port=514 src-address=0.0.0.0 syslog-facility=local0 syslog-severity=auto target=remote
[admin@routeros] > /system logging add action=remote disabled=no prefix="" topics=!async

I hope this has proven useful.